Another one trash blog…

…is here

Posts Tagged ‘wrt54gl

Hard reset

leave a comment »

Το Hard Reset(30/30/30) πρεπει να χρησιμοποιείτε ΠΡΙΝ και ΜΕΤΑ απο καθε upgrade/downgrade με dd-wrt.

Ετσι καθαριζουμε την NVRAM και επαναφερουμε τις αρχικες ρυθμισεις του router μας.

Το Hard Reset γινεται ως εξης:

1. Εχοντας το router στην τροφοδοσια,πιεζουμε και κραταμε πατημενο το Reset button(το οποιο βρισκεται στο πισω μερος του router) για 30 δευτερολεπτα.

2. Χωρις να αφησουμε το Reset button,αφαιρουμε το βισμα της τροφοδοσιας και συνεχιζουμε να κραταμε το Reset button για ακομα 30 δευτερολεπτα.

3. Συνδεουμε ξανα την τροφοδοσια στο router μας συνεχιζοντας να κραταμε πατημενο το Reset button για τα τελευταια 30 δευτερολεπτα. Αφηνουμε το Reset button και το Hard Reset εξετελεσθει!!!

Προσοχη:Κατα την διαρκεια του Hard Reset δεν αφηνουμε καθολου το reset button!

Advertisements

Written by v4nelle

20 April, 2010 at 3:31 am

Posted in linux

Tagged with , ,

DD-wrt installation

leave a comment »

*Στο παραδειγμα μας το dd-wrt firmware που χρησιμοποιησαμε ηταν το dd-wrt.v24_std_generic.bin!

*Αν το router σας εχει το Default Firmware,τοτε πρεπει να περασετε πρωτα το dd-wrt.v24_micro_generic.bin και μετα να περασετε το dd-wrt.v24_std_generic.bin! Αυτο χρειαζεται σιγουρα στο WRT54GL! Για αλλα routers διαβαστε στο wiki του dd-wrt…

Web interface:Αν εχουμε στο router-ακι μας το original firmware ή καποιο αλλο firmware το οποιο μας δινει την δυνατοτητα ρυθμισης του router μας μεσω web interface κανουμε ως εξης:

  • Κανουμε επαναφορα εργοστασιακων ρυθμισεων(Restore Factory Defaults)
  • Κανουμε ενα Hard Reset(30/30/30)
  • Μπαινουμε στο web interface του router μας οπου βρισκουμε το (Firmware Upgrade)
  • Μεσω του (Firmware Upgrade) επιλεγουμε το dd-wrt.v24_std_generic.bin και παταμε το κουμπι (Upgrade)
  • Περιμενουμε 2 λεπτα.Το router θα κανει επανεκινηση οταν τελειωσει το upgrade
  • Κανουμε ξανα Hard Reset(30/30/30) και καθαριζουμε το cache του broswer μας.
  • Αυτο ηταν!Ανοιγουμε τον broswer μας στην διευθυνση http://192.168.1.1 και ολα κομπλε!

MTD:Αν εχουμε στο router-ακι μας καποιο firmware οπως το OpenWrt ή κάποιο παρομοιο στο οποιο δεν υπαρχει web interface κανουμε τα εξης:

  • Κανουμε ενα Hard Reset(30/30/30)
  • Μεταφερουμε το dd-wrt.v24_std_generic.bin στο router μας (στον καταλογο /tmp) με scp. πχ: ~$ scp dd-wrt.v24_std_generic.bin root@192.168.1.1:/tmp
  • Κανουμε μετονομασια στο dd-wrt.v24_std_generic.bin αλλαζωντας την καταληξη .bin σε .trx
  • Κανουμε το upgrade ως εξης: ~$ mtd -e linux -r write dd-wrt.v24_std_generic.trx linux
  • Περιμενουμε 2 λεπτα.Το router θα κανει επανεκινηση οταν τελειωσει το upgrade
  • Κανουμε ξανα Hard Reset(30/30/30) και καθαριζουμε το cache του broswer μας.
  • Αυτο ηταν!Ανοιγουμε τον broswer μας στην διευθυνση http://192.168.1.1 και ολα κομπλε!

Written by v4nelle

20 April, 2010 at 3:31 am

Posted in linux

Tagged with , ,

Openwrt installation

leave a comment »

*Στα παραδειγματα μας το openwrt firmware που χρησιμοποιησαμε ηταν το openwrt-wrt54g-2.4-squashfs.bin(web interface) και openwrt-brcm-2.4-squashfs.trx(MTD)

Installation

Via Web interface:Αν εχουμε στο router-ακι μας το original firmware ή καποιο αλλο firmware το οποιο μας δινει την δυνατοτητα ρυθμισης του router μας μεσω web interface κανουμε ως εξης:

  • Κανουμε επαναφορα εργοστασιακων ρυθμισεων(Restore Factory Defaults)
  • Ενεργοποιουμε το Boot Wait (αν υπαρχει σαν επιλογη στο router μας)
  • Μπαινουμε στο web interface του router μας οπου βρισκουμε το (Firmware Upgrade)
  • Μεσω του (Firmware Upgrade) επιλεγουμε το openwrt-wrt54g-2.4-squashfs.bin και παταμε το κουμπι (Upgrade)
  • Περιμενουμε 2 λεπτα.Το router θα κανει επανεκινηση οταν τελειωσει το upgrade
  • Καθαριζουμε το cache του broswer μας.
  • Αυτο ηταν!Ανοιγουμε τον broswer μας στην διευθυνση http://192.168.1.1

Via MTD:Αν για καποιο λογο στο routerακι μας δεν υπαρχει web interface κανουμε τα εξης:

  • Ενεργοποιουμε το Boot Wait (αν υπαρχει σαν επιλογη στο router μας)
  • Μεταφερουμε το openwrt-brcm-2.4-squashfs.trx στο router μας (στον καταλογο /tmp) με scp. πχ: ~$ scp openwrt-brcm-2.4-squashfs.trx root@192.168.1.1:/tmp
  • Κανουμε το upgrade ως εξης: ~$ mtd -e linux -r write openwrt-brcm-2.4-squashfs.trx linux
  • Περιμενουμε 2 λεπτα.Το router θα κανει επανεκινηση οταν τελειωσει το upgrade
  • Καθαριζουμε το cache του broswer μας.
  • Αυτο ηταν!Ανοιγουμε τον broswer μας στην διευθυνση http://192.168.1.1

Configuration(σε WRT54GL)

Τωρα πρεπει να αποκτησουμε προσβαση στο openwrt.Αν εχουμε linux χρησιμοποιουμε κονσολα.Αν εχουμε windows χρησιμοποιουμε Putty Για να ολοκληρωθει η εγκατασταση και να βαλουμε κωδικο στο router μας κανουμε τα εξης:

1.Συνδεση με telnet

  • Κάνουμε σύνδεση με telnet 192.168.1.1
  • root@OpenWrt:/# passwd
  • Changing password for root New password:(γραφουμε τον κωδικο)
  • Retype password:(κανουμε επιβεβαιωση)
  • root@OpenWrt:/# exit
  • Connection closed by foreign host.

Απο δω και περα θα χρησιμοποιουμε συνδεση μεσω ssh η οποια ειναι περισσοτερο ασφαλης!

2.Συνδεση με ssh

  • ~$ ssh root@192.168.1.1
  • Are you sure you want to continue connecting (yes/no)? yes
  • root@192.168.1.1’s password:(βαζουμε κωδικο)

3.Erase nvram(δοκιμασμενο σε WRT54GL)

Αν εχουμε χρησιμοποιησει πριν καποιο αλλο firmware οπως dd-wrt καλο θα ηταν να διαγραψουμε το vnram καθως αν εξαιρεσουμε το Boot Wait το kamikaze δεν χρησιμοποιει αλλες παραμετρους. Αν και πριν ειχαμε OpenWrt δεν χρειαζεται να το κανουμε Αυτο γίνεται κανοντας:

  • ~$ mtd -r erase nvram

4.Boot Wait

Tωρα θα ενεργοποιησουμε το boot wait ωστε σε περιπτωση καποιου προβληματος να μπορεσουμε να σωσουμε το routerακι μας

  • ~$ nvram set boot_wait=on
  • ~$ nvram set boot_time=10
  • ~$ nvram commit && reboot

Mετα απο την τελευταια εντολη θα δουμε το router να κανει reboot…Στην συνεχεια συνδεομαστε ξανα μεσω ssh στο router μας και συνεχιζουμε παρακατω…

5.Edit Wireless

Σε αυτο το σημειο θα ενεργοποιησουμε το wireless του router μας καθως απο default ειναι disable.Εχουμε και λεμε λοιπον:

root@OpenWrt:/etc# cd /etc/config/

root@OpenWrt:/etc/config# ls

dhcp dropbear firewall network system wireless

root@OpenWrt:/etc/config# vi wireless

config wifi-device wl0

option type broadcom

option channel 5

# disable radio to prevent an open ap after reflashing:

option disabled 1

config wifi-iface

option device wl0

option network lan

option mode ap

option ssid OpenWrt

option hidden 0

option encryption none

~ ~

– wireless 1/14 7%

Οπως λεει και το ιδιο το αρχειο βαζουμε comment(προσθετουμε #) στην γραμμη:

  • option disabled 1

Και αλλαζουμε αν θελουμε το ονομα του SSID αλλαζωντας το OpenWrt σε οτι θελουμε:

  • option ssid OpenWrt

Για να κανουμε αυτες τις αλλαγες πρεπει πρωτα να πατησουμε “i”…Τωρα κανουμε τις αλλαγες και το αρχειο τωρα πρεπει να μοιαζει καπως ετσι:

config wifi-device wl0

option type broadcom

option channel 5

# disable radio to prevent an open ap after reflashing:

# option disabled 1

config wifi-iface

option device wl0

option network lan

option mode ap

option ssid OpenWrt

option hidden 0

option encryption none

~ ~

– wireless 1/14 7%

Μετα τις αλλαγες παταμε το πληκτρο “Esc” και γραφουμε “wq” για να αποθηκευτουν οι αλλαγες και να βγουμε απτον “vi”…

:wq

6.Edit Network

Αφου βρισκομαστε ακομα στο /etc/config/ κανουμε τα εξης:

root@OpenWrt:/etc/config# vi network

#### VLAN configuration

config switch eth0 option vlan0 “1 2 3 4 5*”

option vlan1 “0 5″

#### Loopback configuration

config interface loopback

option ifname ”lo”

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

#### LAN configuration

config interface lan

option type bridge

option ifname ”eth0.0″

option proto static

option ipaddr 192.168.1.1

option netmask 255.255.255.0

#### WAN configuration

config interface wan

option ifname ”eth0.1″

option proto dhcp

~ ~

network

Σε αυτο το σημειο πρεπει να προσθεσουμε 2 options στο LAN section:

  • option gateway
  • option dns

Για να γινει αυτο παταμε “i” και αλλαζουμε το LAN configuration section ως εξης:

#### LAN configuration

config interface lan

option type bridge

option ifname ”eth0.0″

option proto static

option ipaddr 192.168.33.1

option netmask 255.255.255.0

option gateway 192.168.1.254

option dns 192.168.1.254

μετα παταμε “Εsc” και γραφουμε ξανα “wq”

:wq

Αυτο ηταν!

Γραφουμε "reboot" και παταμε Enter

Written by v4nelle

19 April, 2010 at 2:03 pm

Posted in linux

Tagged with , ,